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rmarkdown :

What is rmarkdown? A&
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.Rmd files - Develop your code and
ideas side-by-side in a single
document. Run code as individual
chunks or as an entire document.
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== = Reproducible Research - Upload, link 1
] to, or attach your report to share. 12

Dynamic Documents - Knit together
plots, tables, and results with
narrative text. Render to a variety of
formats like HTML, PDF, MS Word, or
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@Q Anyone can read or run your code to £
reproduce your work. ::
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Workflow s
o Open a new .Rmd file in the RStudio IDE by ;;

going to File > New File > R Markdown. 1

o Embed code in chunks. Run code by line, by o
chunk, or all at once.

e Write text and add tables, figures, images, and
citations. Format with Markdown syntax or the
RStudio Visual Markdown Editor.

o Set output format(s) and options in the YAML
header. Customize themes or add parameters
to execute or add interactivity with Shiny.

Save and render the whole document. Knit
periodically to preview your work as you write.

e Share your work!

Embed Code with knitr

CODE CHUNKS

Surround code chunks with ***{r}and ** * or use
the Insert Code Chunk button. Add a chunk label
and/or chunk options inside the curly braces afterr.

“*{r chunk-label, include=FALSE}
summary(mtcars)

SET GLOBAL OPTIONS
Set options for the entire document in the first chunk.

“*{r include=FALSE}
knitr::opts_chunk$set(message = FALSE)

INLINE CODE

Insert *r <code>" into text sections. Code is evaluated
atrender and results appear as text.

"Builtwith "r getRversion()" " --> "Built with 4.1.0"

== posit

MS Powerpoint. 97

Console Terminal

output created:

VISUAL EDITOR

@ reporcima

R Markdown

. CHEATSHEET

Katonsae | A gk -

: "Document Title" set insert goto runcode

: "Author Name" preview code code chunk(s) show

output: location chunk chunk outline

html_document:

toc: true
4, Set Output Format(s)
and Options

{r setup, includWm )
knitr::opts_chunksset (echo = TRUE
## R Markdown i

3. Write Text runall

This is an R Markdown document. modify gﬁ‘gﬁ:s
raem 1 3 e frmcne chunk
e vord 8 Tk, P options current
an jord documents. ) chunk

{r cars}
summary (cars

2. Embed Code O

Background Jobs

o e

Render

rmarkdownjreport Amd

report.html,
add/edit
attributes

Knitonswe | gk - . @-

Norml f & Fomat+ inser < Tabie

g Pts

style optioﬁs insert citations

This is an R Markdown document. Markdown is a simple formatting syntax for
authoring HTML, PDF, and MS Word documents.

OPTION  DEFAULT EFFECTS
echo TRUE  display code in output document
error FALSE  [ALSE st randor when eher becurs)
eval TRUE  runcodein chunk
include TRUE  include chunk in doc after running
message TRUE  display code messages in document
warning TRUE  display code warnings in document
asis" (passthrough results)

results "markup" "hide" (don't display results)

"hold" (put all results below all code)
fig.align "default” "left", "right", or "center"
fig.alt NULL  alt text for a figure
fig.cap NULL  figure caption as a character string
fig.path "figure/" prefix for generating figure file paths
fig.width & 7 plot dimensions in inches
fig.height
out.width rescales output width, e.g. "75%", "300px"
collapse FALSE  collapse all sources & output into a single block
comment "##"  prefix for each line of results
child NULL files(s) to knit and then include
purl TRUE include or exclude a code chunk when

extracting source code with knitr::purl()
See more options and defaults by running str(knitr::opts_chunk$get())

SOURCEEDITOR [¢° e

m report.htm!

" =outine

RENDERED OUTPUT

file path to output document

~/Desktopireportjreport.htmi

Open in Browser Find “- Publish -~
find in document i ht
H publish to
Document Title  Lucion
shinyapps.io,

Author Name Posit Connect

« R Markdown
« Including Plots

R Markdown

This is an R document is a simple
syntax for authoring HTML, PDF, and MS Word documents. For more
details on using R Markdown see http://rmarkdown.rstudio.com.

reload document

summary (cars)

## speed
# Min.  : 4.
## st Qu.:12.

0 Min. : 2.00
0
## Median :15.0
4
0
0

1st Qu.: 26.00
Median : 36.00

## Mean  :15. Mean  : 42.98
## 3rd Qu.:19. 3rd Qu.: 56.00
## Max.  :25. Max.  :120.00

@ report hum 690.7K8  May 5, 2023, 7:11PM

Insert Citations

Create citations from a bibliography file, a Zotero library,
or from DOI references.

BUILD YOUR BIBLIOGRAPHY
Add BibTeX or CSL bibliographies to the YAML header.

title: "My Document"
bibliography: references.bib
link-citations: TRUE

If Zotero is installed locally, your main library will
automatically be available.

Add citations by DOI by searching "from DOI" in the
Insert Citation dialog.
INSERT CITATIONS

« Access the Insert Citations dialog in the Visual Editor
by clicking the @ symbol in the toolbar or by clicking
Insert > Citation.

« Add citations with markdown syntax by typing [@cite]
or @cite.

Insert Tables

Output data frames as tables using

Table with kable
eruptions  waiting

kable(data, caption). .
- 10 s

{ s T
data <- faithful[1:4, ] 28 &

knitr::kable(data,
caption = "Table with kable")

Other table packages include flextable, gt, and kableExtra.

Write with
Markdown

The syntax on the left renders as the output on the right.

Plain text.

End a line with two spaces to
start a new paragraph.

Also end with a backslash\
to make a new line.

*italics® and **bold**
superscriptA2”/subscript~2~
~~strikethrough~~

escaped: \"\_\\

endash: -, emdash: ==

# Header 1
## Header 2

i Header 6

- unordered list

-item
-item 2a (indent 1 tab)
-item 2b

1. ordered list

2.item 2
-item 2a (indent 1 tab)
-item 2b

<linkurl>
[Thisis a link.](link url)
[Thisis another link][id].

At the end of the document:
[id]: link url

I[Caption](image.png)
or I[Caption][id2]
At the end of the document:
[id2]: image.png

“verbatim code”

multiple lines
of verbatim code

> block quotes
equation: $ei\pi}+1=0$

equation block:

$SE =mcM215S

horizontal rule:

| Right | Left | Default | Center|

|
[12]12]1212]
|123]123|123] 123
FYRAETRY

HTML Tabsets
## Results { tabset}
### Plots

text

#i#t# Tables
more text

Plain text.

End a line with two spaces to
start a new paragraph.

Also end with a backslash
to make a new line.

italics and bold
superscript?/subscript,

escaped: * _\
endash: -, emdash: —

Header 1
Header 2

ﬁeader 6

« unordered list

. item2

« item Zg (indent 1 tab)
2l

« item

1. ordered list

2. item2
« item 2a (indent 1 tab)
« item2b

http://www.posit.co/
Thisis alink.
This is another link.

Caption.

verbatim code

multiple lines
of verbatim code

block quotes

equation: e +1 =0
equation block:

E =mc?
horizontal rule:
Right Left Default Center
12 12 12 12
123 123 123 123
11 1 1
Results
Plots  Tables
text
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. . . °
Set Output Formats and their Options in YAML . _Ez Render
Use the document's YAML header to set an output IMPORTANT OPTIONS ~ DESCRIPTION Fggsg When you render a rmarkdown
format and customize it with output options. anchor_sections Show section anchors on mouse hover (TRUE or FALSE) X document, rmarkdown:
- citation_package The LaTeX package to process citations ("default", "natbib", "biblatex") X 1. Runs the code and embeds
title: "My Document" " : results and text into an.md
auzhoz . "Author Name" co:e_:ol:mluad (L3|ve re:ders an op':lor:]toddomlmloadethed.Rmd sourcehczde (TRU: or FALSE) i file with Knitr
ou ut: H B " (e Ty ", "
himl document:  |ndent format 2 characters, SRELBLILE slizaderstolvesigthediplayiiicodinonchindeplorichonj) 2. Converts the .md file into the output format with
toc: TRUE indent options 4 r.haracters’ css CSS or SCSS file to use to style document (e.g. "style.css") X Pandoc.
- ::v ' Gra;:]hi;:sfdevif:e fo u:e fo; figure (Tll;tpfut l(e".gv:k"pbr:g:, :pz:) B . X X .Rm’} e [ N pando Lr[;.;{ N
OUTPUT FORMAT CREATES ._prlnt. Metho 'or printing data ramés( eéut, able", "tibble", "paged") X X X X Dpoc
html_document html fig_caption Should figures be rendered with captions (TRUE or FALSE) X X X X Save, then Knit to preview the document output.
pdf_document* .pdf highlight Syntax highlighting ("tango", "pygments", "kate", "zenburn", "textmate") X X X The resulting HTML/PDF/MS Word/etc. document will
word_document Microsoft Word (.docx) includes File of content to place in doc ("in_header", "before_body", "after_body") X X ?}?ecr;;tg?ilznd saved in the same directory as
powerpoint_presentation  Microsoft Powerpoint (.pptx) keep_md Keep the Markdown .md file generated by knitting (TRUE or FALSE) X X X X ’ : "
odt_document OpenDocument Text . " N Use rmarkdown::render() to render/knit in the R
rtf_document o — keep_tex Keep the intermediate TEX file used to convert to PDF (TRUE or FALSE) X console. See 2render for available options.
md_document Markdown latex_engine LaTeX engine for producing PDF output ("pdflatex", "xelatex", or "lualatex") X
github_document Markdown for Github reference_docx/_doc docx/pptx file containing styles to copy in the output (e.g. "file.docx", "file.pptx") X X S h a re
io.slides_presen.tation i0§lides HTMIT slides theme Theme options (see Bootswatch and Custom Themes below) X Publish on Posit Connect
slldy_presentatlon. N Slidy HTM!— slides toc Add a table of contents at start of document (TRUE or FALSE) X X X X to share R Markdown documents
beamer_presentation Beamer slides toc_depth The lowest level of headings to add to table of contents (e.g. 2, 3) X X X X securely, schedule automatic [ ] o
* i i A
AlRequ'rEj LaJTeXL,Luse tl"yte{"l"sm“af':}l’ltex(z L toc_float Float the table of contents to the left of the main document content (TRUE or FALSE) X updates, and interact with parameters in real-time.
s0 see f b istill, an: g .
Use ?<output format> to see all of a format's options, e.g. Zhtml_document osit.co/products/enterprise/connect.
PARAMETERS BOOTSWATCH THEMES STYLING WITH CSS AND SCSS INTERACTIVITY
Parameterize your documents to reuse with new Customize HTML documents with Bootswatch Add CSS and SCSS to your document by adding a Turn your report into an interactive
inputs (e.g., data, values, etc.). themes from the bslib package using the theme path to a file with the css option in the YAML header. Shiny document in 4 steps:
-— output option. ime: shi
1. Add parameters poroms: P ¢ P ) ] o 1. Add runtime: shiny to the YAML header.
in the header as state: "hawaii" Use bslib::bootswatch_themes() to list available title: "My Document™ 2. Call Shiny input functions to embed input objects.
r - themes. Feon " . . .
sub-values of author: "Author Name 3. Call Shiny render functions to embed reactive
params. et —— output: output.
data <- df ‘e : con : " html_document: . "
2. Call parameters sSm;a:y(daEQ)params$s Bl :Jﬁ;gr: Rgﬁzwgpt,‘;}g}e css: "style.css" 4. Renderwith rmark(!own::run()orcllck Run
in codesusing o output: - Document in RStudio IDE.
paramss<name=>. html_document: . - .
A Wl T theme: Apply CSS styling by writing HTML tags directly or: e How many cars?
3. Setparameters | - - bootswatch: solar  « Usemarkdown to apply style attributes inline. output: html_document s :
with Knit with - ot o POF —— runtime: shiny 4
Parametersorthe |~ ™% Bracketed Span -
params argument | "ot A[green]{.my-color} word. Agreen word. s _ spoed | dist
of render(). Knit with Parameters.. CUSTOM THEMES {r, echo = FALSE}
F d Di numericInput("n", 1 4.00 2.00
REUSABLE TEMPLATES Customize individual HTML elements using bslib me{nr%eicof(\)/ﬂ "How many cars?", 5) 2 4.00 10.00
variables. Use ?bs_theme to see more variables. A.H.oth/hese vords 3l 700 4.00
1. Create a new package with a inst/rmarkdown/ w All of these words reEdegTable € : .
templates directory. - are green. are green. n ead(cars, input$n) 4 7.00 22.00
2. Add afolder containing template.yaml (below) OUEEU{:d . o 5 8.00 16.00
ml_document: N -
TE‘ skeleton.Rmd (template contents). theme: « Use the Visual Editor. Go to Format > Div/Span and .
name: "My Template" bg: "#121212" add CSS styling directly with Edit Attributes. Also see Shiny Prerendered for better performance.
name: fg: "HEAE4E4" ) rmarkdown.rstudio.com/
3. Install the package to access template by going to base_font: ' authoring_shiny_prerendered.

google: "Prompt" .my-css-tag  eee

- This is a div with some text in it Embed a complete app into your document with
More on bslib at pkgs.rstudio.com/bslib). ) shiny::shinyAppDir(). More at bookdown.org/yihui
rmarkdown/shiny-embedded.html.

L]
®
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File > New R Markdown > From Template.



A mixture of tools and languages

R Markdown file

O -0y

VAML

|

ZCoPE

=X =X




Other features

* PDF: LaTeX

* Maths: LaleX

* Customized HTML documents: CSS (ou SCSS)

* Diagrams: mermaid or GraphViz

* Other high-level programming languages: Python, Julia, SQL
e Other: bash, Rcpp (C++), Stan (statistiques bayésiennes),



The default document

File > New File > R Markdown...
Procedure:
o create adocument,

o change the default values,

o change
o headers,
o text,
o Rcode,

o save document as an Rmd file.

o Click on “Knit”

& Knit ~

New R Markdown

') Document
CJ Presentation
R Shiny

From Template

Create Empty Document

Title: Untitled

Author: | Vincent Guillemot

Date: 2025-05-23

Use current date when rendering document
Default Output Format:

® HTML

Recommended format for authoring (you can switch to
PDF or Word output anytime).

O PDF

PDF output requires TeX (MiKTeX on Windows, MacTeX
2013+ on OS X, TeX Live 2013+ on Linux).

O word

Previewing Word documents requires an installation of
MS Word (or Libre/Open Office on Linux).

OK Cancel



Exercise: modify the default document

1. Select « HTML » output format
2.Change title to “Document 1: title and text”
3. Change author

4. Change text:

1. Header to “Header”
2. Text to “I’m learning R Markdown!”

5. Save this file as “document1-simple.Rmd”
6. Compile by clicking on “Knit"



The structure of an R Markdown file

* YAML header: title, author, date, etc.

title: "Untitled"

author: "Vincent Guillemot"
date: '"2025-05-23"

output: html_document



The structure of an R Markdown file

e Text in Markdown

## R Markdown

This is an R Markdown document. Markdown is a
simple formatting syntax for authoring HTML,
PDF, and MS Word documents. For more details on
using R Markdown see
<http://rmarkdown.rstudio.com>.

When you click the **Knit** button a document
will be generated that includes both content as
well as the output of any embedded R code chunks
within the document. You can embed an R code
chunk like this:

10



The structure of an R Markdown file

e Rcodein chunks

o r

e

cars

}

This chunk

is called
“CarS”

summary(cars)

—_
Thisisan R
chunk

N

It contains

this set of R
commands

11



The structure of an R Markdown file

Its code is executed but

nothing is shown on the

* Setup chunk output file

T~

This R chunkis “*{r setup|, [include=FALSE}|
called “setup knitr: :opts_chunk$set(echo = TRUE))

It sets the values of chunk
All chunks have these little

options for all the other

chunks buttons, they are here to

help you!

12



Exercise

title: "Untitled"
author: "Vincent Guillemot"
date: "2025-05-23"

* Create an R Markdown document called
output: html_document

« document2-justeAtitle.Rmd »

* Compile it by clicking « Knit »

 The result should look like this
& Knit ~

Le document avec juste un titre

Jean-Edmond Synthétique
1er avril 1956

13



The “text” part is written in
Markdown

It’s another language entirely... but intuitive! | R Help
Il Search R Help

| About RStudio
| Check for Updates

Markdown Quick Reference

( .o ) Accessibility

Emphasis RStudio Docs

*italiC* **bold** RStudio Community Forum
ita |.| C bO '.d Cheat Sheets

- - T o Kevboard Shortcuts Help

H eader S Markdown Quick Reference

# Header 1 ## Header 2 ### Header 3 RoXygen QuIck Rererence

Diagnostics

14



Exercise

Create an R Markdown called “document3-just_blabla.Rmd”
that will look like this:

e Les chaussettes de I’'archiduchesse sont-elles seches ?
e ARCHI-seches ?

15



Chunks

" {r moins3a3aucarré, echo=FALSE}
plot((-3:3)72)

AR NN

Chunk Name: | moins3a3aucarré

Output: [ Show output only V]

@ Show warnings

() Show messages

() Use paged tables

(1)) Use custom figure size

2) Chunk options Revert | | Apply

Run all the previous chunks

(-3:32

P Runthe code inside this chunk

16



Exercise

 Create an R Markdown
document called
« document4-complete.Rmd »,

with
* a YAML header
* Markdown text
* Two R chunks

* That will compile into the
following HTML document ->

Un diagramme en batons

Vincent Guillemot
2025-05-25

Génération des données

x <= 1:3

Diagramme en béatons

barplot(x, col = 1:3)

o
I
©w
o
o
N
w
o |
w
o
o
o

17



Final exercise: the first
useful R Markdown
document

Create an R Markdown document that will
contain:

1. An R chunk to load the COVID
dataset

2. An R chunk to show the expression
of CD4 for all cases

3. A title, your name and the date
4, Some text

Work in groups

i |

i

Normalized log, counts
N »
T T

o
(=)

CD4

r—rr11
4 567 8 910111213 17181920

Days postillness onset

18



